Adium

Adium 1.3.5rc1

Howdy folks. We’ve posted a release candidate for 1.3.5rc1. I don’t want to deal with having two betas simultaneously, so we’re keeping it short and simple here on the blog. The only changes are in libpurple and the Facebook chat plugin. Please respond here with any issues specifically related to 1.3.5 over 1.3.4.

1.3.5rc1.dmg (MD5 ba46df4857871bfa5eed3170f0961b05)

Libpurple changes in 2.5.7:

  • Yahoo Protocol 16 support, including new HTTPS login method; this should fix a number of login problems that have recently cropped up. (Sulabh Mahajan, Mike “Maiku” Ruprecht)
  • Only display the AIM “Unable to Retrieve Buddy List” message once per connection. (Rob Taft)
  • Blocking MSN users not on your buddy list no longer disconnects you.
  • When performing operations on MSN, assume users are on the MSN/Passport network if we don’t get network ID’s for them. [this fixes adding/removing and getting disconnected]

pidgin-facebookchat changes in 1.51:

  • Fix idle status of buddies
  • Less disconnects for people with large friends lists
  • gzip compression for smaller page downloads
  • Fixes for notifications for non-English users
  • Display messages sent from website in Pidgin
  • Inbox count display
  • Usernames and/or passwords with utf-8 characters should work now
  • Display *bold* and _underline_ formatting in incoming messages
  • Memleak fixes
  • Proxy server fixes
  • Fixed some crashes on disconnect
  • Fixes some buddy's appearing offline when they weren't
  • New channel finding code, should mean less conflicts with Facebook website

23 Responses to “Adium 1.3.5rc1”

  1. Dan C Says:

    Smurf, OS X 10.4.11, fully updated.

    First launch of 1.3.5rc1: Blank contacts window and this in system log:

    Jun 21 16:02:35 dans-smurftower kernel[0]: IOAudioStream[0x1908e00]::clipIfNecessary() – Error: attempting to clip to a position more than one buffer ahead of last clip position (2,c3d)->(3,3815).
    Jun 21 16:02:35 dans-smurftower kernel[0]: IOAudioStream[0x1908e00]::clipIfNecessary() – adjusting clipped position to (3,c3d)
    (followed by umpteen “Invalid colorspace type” messages, as usual)
    (then)
    SocketRead: read(5) error 0
    SocketRead err = -9802

    Second launch: Empty Contacts window for about a minute, then it populated. Same log messages.

    Third launch: The contacts window populated sooner, but my Yahoo account never connected.

    How ’bout a debug build?

    - Dan.

  2. Beth C Says:

    I am having a problem logging in to yahoo after a computer crash and I lost all my settings. I need help asap as I use yahoo for my business

  3. Beth C Says:

    It just hangs there. I have all my other setting in, msn, gmail, facebook, LiveJournal. All these I use for my business. I use yahoo most and now I cannot connect. Step by step instruction on how to fix would be appreciated. And as soon as possible.

  4. Steve Says:

    Same as Beth… it’s totally screwed. I use it for business as well. Fire doesn’t work either. Beta logs in the accounts but you get every yahoo response repeated when you get messaged.

  5. Adam Says:

    Works great under Mac OS X 10.5.7! Thanks!

  6. Vincenzo Says:

    Where did Twitter go? It was there in the 1.3.4 beta release.

  7. Vincenzo Says:

    Ok, I was drunk. The beta I was talking about is actually the 1.4 beta, with the Twitter support. Fair enough, ignore me :D

  8. Lance E Sloan Says:

    I hear that 1.3.5 fixes some recent Yahoo! connect problems. What about the recent QQ connect problems? Is that fixed in this version, too?

  9. Marcos Wright Kuhns Says:

    Yahoo! and Google Talk are working like a charm for me on OS X 10.4.11. I can’t wait to upgrade to Snow Leopard so I can test out Adium 1.4!

  10. Hiu C Says:

    Hello, I’ve been having trouble logging into MSN for a few days now. I’ve updated with the most recent update and tried removing my Xtras and accounts but it still has problems… would anyone have any other suggestions?

  11. Hiu C Says:

    ok nevermind…. i just restarted and it works now haha please disregard my post!
    thanks!

  12. Dan C Says:

    I see 1.3.5 has been released.

    Having the same problem as reported above here, on both my Smurf and PB G4 (Tiger)… It just sits there saying “Connecting” for the Yahoo account.

    How ’bout a debug build?

    Thx,
    - Dan.

  13. David Chin Says:

    Connection works fine, and I’m able to see my Yahoo buddy list, but their profile thumbnail images are not showing.

    Furthermore, Get info on a contact shows “error retrieving profile – This profile is in a language or format that is not supported at this time.”

  14. efren Says:

    just a suggestion um can u add also friendster chat the same way you add with the facebook chat

  15. Alex Sleeis Says:

    Adium doesn’t seem to be consistently tracking whether my friends are idle, away, or even logging off!! I’ve had friends stay in away state, but be online, or show as online and have long since gone idle/away or even having logged out. I am not sure if it specific to an IM service or not. I have definitely noticed it with a couple Yahoo friends. Thanks for fixing the Yahoo login issue, but for me, 1.3.4 was far more stable and far buggy. Maybe it’s related to other changes in Yahoo that are still not fully hashed out, but I would really like to see a fix soon. :(

  16. js Says:

    i am having an issue where whenever one of my yahoo contacts IMs me it comes in twice… every time. Really driving me crazy.

  17. Peter da Silva Says:

    I saw facebook listed and got all excited, since my brother just talked me into joining facebook… but when I try to connect nothing happens and in the log file it says:

    09-06-23 16:37:40 Adium[20106] Could not connect the action changeServiceName: to target of class PurpleFacebookAccountViewController
    09-06-23 16:37:40 Adium[20106] *** Illegal NSOutlineView data source (). Must implement outlineView:numberOfChildrenOfItem:, outlineView:isItemExpandable:, outlineView:child:ofItem: and outlineView:objectValueForTableColumn:byItem:

    Poor Adiumy is sad. :)

  18. Tess Says:

    After the update to 1.3.5 I am having no luck sending/receiving IMs from most of my coworkers. They use Trillian, Yahoo Messenger, MSN Messenger mostly. However I can receive/send IMs with another coworker on Adium same version and someone outside of my work network on AIM. I’ve submitted a ticket for this, but curious if anyone else is having these issues?

  19. drew Says:

    Having the same issue as Alex Sleeis. My contacts log in and out, but adium doesn’t accurately reflect the changes, particularly when people sign off.

  20. KiM Says:

    Sorry guys, but I am disappointed… the new release does nothing to fix my facebook woes… I know you are using a 3rd party plugin, but still…

    I would also like to add that your mail features neat… but, how do I turn it OFF! I find myself, not only having to click once each time I open computer on the facebook login prompt, but now I have to click again for the “you have new mail” feature… I really don’t want any dialog boxes, thank you.

    Thanks for the effort tho!

  21. Tux Says:

    I’ve updated to Adium 1.3.5, after having troubles with Yahoo previously. I cannot view correctly contacts’ status, idle, etc. Contact aliases are lost. For all contacts, GetInfo returns “This profile is in a language or format that is not supported at this time.”.
    Any chance we could see an update soon to libpurple / Adium ? Thank you for continuous efforts!

  22. Kim Simonsen Says:

    Why are all my facebook contacts listed without profile picture (only the facebook logo), when all my messenger contacts are listed with their profile picture?

  23. JL Says:

    My contacts’ profile pictures do not show up in BOTH Yahoo! and Facebook. :(
    And, when a contact disconnects, I do not see them go offline. They just stay online until I close Adium.
    It’s really annoying. Gah. Sorry, I love Adium. It was working very well just a month ago. :o