[Adium-devl] GSoC 2007 student branches

Evan Schoenberg evan at adiumx.com
Wed May 30 20:03:14 UTC 2007


On May 30, 2007, at 3:42 PM, Michael wrote:

>> So push 1.0.5 beta now with purple changes, and leave it in beta  
>> until
>> 1.1 and then do a dual release? Sounds pretty good, but: Are there
>> semantics in sparkle for not upgrading someone who is on an OS we no
>> longer support? If not, we'll need to do 1.0.5 anyway to add that. We
>> don't want a 10.3 user having Adium be horked because they  
>> download 1.1.
>>
>> How did we do this for 0.89.1 -> 1.0?
>>
> Yes, a dual release. Or 1.0.5 shortly after 1.1 but only for 10.3  
> users
> as the others will have skipped/moved to 1.1.
>
> I don't know about Sparkle's inner workings, I believe this will be  
> the
> first time Adium hits this as -IIRC- Sparkle was introduced in 1.0  
> (betas).

Let's do 1.0.5 beta now in any case for sure, and see how we shape up  
for 1.1.

And yes, there's a mechanism for specifying a minimum system version  
on which the release should be shown... *however* I'm not sure about  
how sparkle handles an appcast with multiple versions available.  It  
needs to be investigated what happens if appcast.xml has:

  * version 1.2, minimum system requirement 10.4.0
  * version 1.0.6, minimum system requirement 10.3.9

while (1) one is running 1.0.5 and (2) while one running 1.1

-Evan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://adiumx.com/pipermail/devel_adium.im/attachments/20070530/2d1e7dae/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
URL: <http://adiumx.com/pipermail/devel_adium.im/attachments/20070530/2d1e7dae/attachment.bin>


More information about the Adium-devl mailing list