Update glib for 1.4?
Evan Schoenberg, M.D.
evan at adium.im
Sun Jul 25 20:26:09 UTC 2010
On Jun 19, 2010, at 6:43 PM, Thijs Alkemade wrote:
> Hello adium-developers!
> I noticed today http://trac.adium.im/ticket/13351 is not completely fixed and
> can still lead to a crash when users have a non-breaking space (0xA0 in some
> character sets, which, on its own, is an illegal sequence in UTF-8) in their
> name (the second crash log on that ticket). Not many IRC servers accept this
> character, irc.rizon.net being a strange exemption
> Why mail the mailing list and not just put a patch on the ticket? Well, the
> crash is deep in glib, and, in fact, a known bug there:
> https://bugzilla.gnome.org/show_bug.cgi?id=531403, which got fixed in 2.17.1.
> It could be worked around, for example in irc_msg_who, but I'm not sure this
> crash could also happen under different circumstances. So that's why I think
> it would be better to upgrade to a libglib version >= 2.17.1 (for example,
> 2.18, or 2.20 so it's equal to the version in 1.5hg tip). I have talked about
> this with rekkanoryo, who said libpurple is not dependent on a specific
> libglib version (as long as it's above 2.12). So that would not cause
> So, to whomever builds the frameworks and dependencies, is upgrading libglib
> possible, and would this be wise considering 1.4 keeps dragging on?
Let's update libglib on 1.5 (trunk) but not on 1.4; I'd rather accept a single known bug as "cantfix on 1.4, fixed for 1.5" than introduce all the new variables of upgrading a major dependency at this point.
Thanks for the detailed exploration of the problem!
More information about the devel