Adium

Yahoo! change

Yahoo! has made a change on their server that prevents Adium 1.3.4 and the 1.4 betas from connecting. We have released a new beta, beta 7, which contains the fix.

As we’ve noted before, 1.4 will require Leopard. Those of you who are still hanging on to Tiger are currently stuck, as we do not yet have a fixed version for you. We’ll release a 1.3.5 shortly after Libpurple 2.5.7 comes out, as that version will also contain the fix. (Libpurple, for those of you who don’t know, is the library Adium uses to connect to Yahoo! and most other services.) The Adium 1.4 betas use pre-release versions of Libpurple 2.6.

48 Responses to “Yahoo! change”

  1. RPMozley Says:

    There’s a temporary fix for people still on Tiger. Go to Preferences->Accounts tab->Select your Yahoo! account and choose to Edit->Select the Options setting->Change the Login Server from the default “scs.msg.yahoo.com” to one of the following addresses “cs101.msg.mud.yahoo.com” up to (and including) “cs127.msg.mud.yahoo.com”

  2. Jake Says:

    Having the problem with Yahoo not connecting so downloaded and installed the new beta. Now I’m getting the double posting problem…. any idea how to fix?

  3. Julian Says:

    My OS is 10.5.7 I downloaded the Beta and it wouldn’t run so I downloaded 1.3.4 Adium and did the fix that RPMozeley suggests. That worked.

    “Go to Preferences->Accounts tab->Select your Yahoo! account and choose to Edit->Select the Options setting->Change the Login Server from the default “scs.msg.yahoo.com” to one of the following addresses “cs101.msg.mud.yahoo.com” up to (and including) “cs127.msg.mud.yahoo.com””

    Note: Why do they give OS releases names and numbers, but never use them in the same place? Is Leopard 10.5.7? Ubuntu do this too. Grr.

  4. Tony Says:

    Ended up going with RPMozley’s suggestion because beta 7 wasn’t working in too many other ways.

    Jabber wouldn’t connect to my work server anymore
    yahoo left people in the contact list who’d been disconnected for hours
    doubleposting in IM windows (at least in yahoo)
    some shuffling around in the contacts window

    I’m giving the list in way of a poor man’s bug report. Jabber was the show stopper for me though.

  5. Ruthie Says:

    I can’t run the beta 7 without the installer popping up on my computer again. I’ve moved Adium to my applications folder and ejected the disk three times now, and yet still when I open Adium, the installer disk pops up on my computer. Any idea as to why this is happening and how to make it stop? I’m tempted to go back to the old Adium and use the fix for Tiger because this is ridiculous!

  6. Ruthie Says:

    The RPMozley fix worked for me, thanks bunches!

  7. D, Says:

    I echo the issues which “Tony” posted above.

    Yahoo leaves contacts which have long since logged out in the contact list
    Yahoo duplicates (replays) messages, several seconds apart.
    I don’t use Jabber but google talk seems to have trouble connecting. Reverting back to 1.3.4 works this

  8. Julian Says:

    google talk is jabber

  9. Hated Greatness Says:

    RPMozley’s solution worked for me on the first try. By the way, I am on Leopard but don’t want to use the beta due to all the issues I have heard about.

  10. Herman Tho Says:

    When adium support Video Chatting?
    i J^st notice that the avatar of my friends is not auto updated to display on adium.

  11. Peter Hosey Says:

    Ruthie: That’s not an installer; it’s a disk image. See http://adium.im/faq/HowToUseDiskImages .

  12. Zee Says:

    This is your punishment for screwing over all those tiger users – a dropping userbase and a fade to irrelevance.

    Congrats…

  13. Petra Hall Says:

    As per the suggestion to try cs101.msg.mud.yahoo.com I was connected right away using 1.3.4. Thanks for the tip!

  14. Nevin Says:

    A side note, QQ also cannot connect now….

  15. solidox Says:

    Wow, no adium (yahoo at least) for tiger users, that was smart … But to be honest, adium is a great messenger and it’s free, so I’ll give you a break.

    Anyway, Libpurple 2.5.7 is out ;)

  16. Robby Says:

    I’m a Tiger user and I don’t feel “screwed over”, zee. Adium 1.3.x works well for me. :)

  17. Brad Says:

    The choice to not release versions compatible with Tiger is once probably made after careful consideration of the features they wished to implement vs. their compatibility with previous versions of OS X. As with any software, if you decide not to upgrade your OS when a new version comes out, you can’t expect to have the latest and greatest from other software…especially when it’s free and they don’t have the commercial support to develop for multiple platforms.

    That being said, I’m sure there will still be security updates and such for previous versions, but keep in mind that those fixes may come some time after the same fix comes to the newer versions. If you can’t deal with that, use a different application. There are many out there.

  18. Jake Says:

    I have leopard and the same issue was happening to me. Changing the pager server to “cn.scs.msg.yahoo.com” in Adium worked. It’s not a OS version thing, and I had the same problem with pidgin on an ubuntu distro.
    I’m wondering if Yahoo changed their US page server and didnt’ tell anyone. Thanks Yahoo.

  19. AndyB Says:

    @ Julian: All of the Mac OS X 10.5 releases are “Leopard”. So yes, 10.5.7 is Leopard. There are several places to find out what codename goes with what numeric version. Wikipedia, for example: http://en.wikipedia.org/wiki/Mac_OS_X#Versions

    @Herman Tho: The Adium roadmap says that voice and possibly video are planned for Adium 2.0. There is no release date set for this version. http://trac.adium.im/roadmap

    @Zee: Not sure what you are saying here. First of all, Tiger is still fully supported in the current version of Adium. There is a beta release being tested that fixes the Yahoo login problem. Second, what dropping userbase? Apparently you have stats on how many users Adium has? I’d love to see them.

  20. Dean Says:

    I’m getting a problem where all of incoming messages from yahoo are double posting, is there a way to fix this?

  21. Peter Hosey Says:

    We’ve just released 1.3.5. Most of you, including Tiger users, should try that instead.

  22. J T Says:

    I jsut upgraded to Adium 1.3.5 and yahoo now longer works. It has a message Error Socket is not connected.

    Just yesterday I solved the problem with Adium 1.3.4 by using the server address 66.163.181.106. Now I need to revert back to 1.3.4 until a solution is made for Adium 1.3.5.

  23. J T Says:

    I just tried cs127.msg.mud.yahoo.com as server. This worked.

    Ignore previous post. Upgrade to 1.3.5 is fine.

  24. audiored Says:

    I’ve tired 3 times to dl the the patch for adium. each time it has taken nearly an hour or more to download. updating form adium itself causes an error. if i download from adiums website the dmg file is not recognized..

  25. webnician Says:

    UPDATE:

    Today’s update fixes the problem, so put the IP address back to: scs.msg.yahoo.com or just delete it and it will auto-fill.

  26. Bullfrog Says:

    Leopard 10.5.7 Users:

    Installed the new Beta 7 and changed the Yahoo server to “scs.msg.yahoo.com” and it works again!

  27. Huy Phan Says:

    Yahoo changed their server again, currently I don’t know what server to use. You guys have any idea ?

  28. bliq Says:

    This won’t work after 5pm today. Trust me :) upgrade to 1.3.5 and scs.msg.yahoo.com will work.

  29. Eel Says:

    just yet had to chang it back to scs.msg.yahoo.com to make it work. the old way didnt work anymore, but inside the beta still.

  30. Amrish Says:

    Upgraded to adium 1.3.5 on OS X 10.5.6.
    I am back online :)
    Using scs.msg.yahoo.com.

  31. Welt Says:

    Yeah thanks, it works again. Been changing the IP address the past few days just to make it work. Avatars for my yahoo messenger buddies are gone though.

  32. Vince Says:

    Using Adium 1.4b6′s Check for Updates feature and it states I have the latest version. Is b7 no longer available to download?

  33. solidox Says:

    Yay, 135!

    Thanks for the awesomely fast release.

    love,
    solidox

  34. Kim Says:

    I was having the same issue with my Yahoo account connecting with Adium 1.3.5. I tried everything that was suggested above with no avail. Then I thought let me try putting “scs.msg.yahoo.com” back in the login server box and I was able to connect.

    This was after I tried “Go to Preferences->Accounts tab->Select your Yahoo! account and choose to Edit->Select the Options setting->Change the Login Server from the default “scs.msg.yahoo.com” to one of the following addresses “cs101.msg.mud.yahoo.com” up to (and including) “cs127.msg.mud.yahoo.com””

    So going back to using the default seemed to work, try it maybe it will work for you too.

  35. Daniel Bogan Says:

    I have the same issue with the double-messages from Y!M. Turns out it’s somehow related to what version (of the official client) the other person is using – older ones don’t do it, but the latest seems to. If that helps, any.

  36. Ruthie Says:

    Peter: I read that link, and I was already doing what it said. But what I wanted to know is this: is the disk image supposed to pop up after you delete it? I was not launching Adium from the disk image, but from my applications folder. I copied it to my applications folder and ejected the disk image three times and it still popped up after I opened Adium. This is not normal, and that’s what I was trying to say, I just said “installer” instead of “disk image.”

    On another note, the 1.3.5 with “scs.msg.yahoo.com” is working fine for me. I would suggest this instead of the beta.

  37. Borg Says:

    i had the same problem…..i was configured with 66.163.181.106 on 1.3.4 (i was using the ip address due to a dhcp issue with 1.3.4.).
    after upgrading to 1.3.5 i got “error: socket is not connected” with the ip address still configured as the login server.
    changing back to scs.msg.yahoo.com on 1.3.5 fixes the problem.

  38. pecgi Says:

    OMG…
    until today.. i cant connect to my adium..
    i’ll try all the IP but didn’t working

    what should I do ?

  39. Joe Says:

    Okay, can connect to Yahoo without that Yahoo popup thing…using the latest beta release from this page…BUT…every Yahoo response posts twice. I get an answer in chat from someone, anda split-second after it pops up again. Anyone, any thoughts?

  40. Tyna Says:

    This update did not help me. I still cannot connect to Yahoo. I have tried changing the IP, this did not help me.

  41. Tim Says:

    I am running the 1.4b7 build and I am getting the double posting problem as well. The person I consistantly see issue with is running the 9.0.0.2034 version of the yahoo client.

  42. Welt Says:

    the avatar of my ym buddies are mostly gone..save for maybe 2. All i can see is the generic ym logo beside their name, for all of them, which is kinda sad.
    Anybody have the same problems.

  43. KENLEY Says:

    hello everyone . did any of you who maybe having the same problem as me contacted YAHOO about the ADIUM upgrade default message ? each time i try to download yahoo messenger on to my IMAC OS X 10.3.9, after the installation process completed, yahoo messenger wont load open . (for that, yahoo will be loosing alot of users). i gonna contact them and see what they got to say about that . ive tried these steps, but it doesnt work .
    _________________________________________________________________________________________________________________________________________________________________________________

    This was after I tried “Go to Preferences->Accounts tab->Select your Yahoo! account and choose to Edit->Select the Options setting->Change the Login Server from the default “scs.msg.yahoo.com” to one of the following addresses “cs101.msg.mud.yahoo.com” up to (and including) “cs127.msg.mud.yahoo.com””

  44. KENLEY Says:

    im able to long on with NO issue whatsoever, but my contact are NOT showing ! what should i do now ???
    e-mail me anyone : warlockwizard@rocketmail.com
    thank you,

  45. Lathain@girlsandnylons Says:

    I haven’t heard anything like that before: Om said Om copied it to his or her applications folder and ejected the disk image three times and it still popped up after he or she opened Adium.

  46. Sandra25@girlsandnylons Says:

    Interesting gossip: unknown person said he copied it to his or her applications folder and ejected the disk image three times and it still popped up after he or she opened Adium.

  47. JL Says:

    I have a problem in Adium. I do not see my contacts disconnect. They just stay online.
    To me, they are online, but they are really offline.
    Another thing. My contacts’ display images do not change. They stay blank.
    I’m using Yahoo! Messenger by the way.

  48. JL Says:

    ***
    This is even AFTER I downloaded the Adium 1.3.5
    I’m using Tiger